Jump to content

1953 Dodge Meadowbrook


Crisjr14
 Share

Recommended Posts

OK I'm here again to ask for some more help please so on a post before I asked about the gearbox arm that I had bent so I put a new on and also replaced the rubber plates to the frame and the gearbox but for some reason when I turn the steering wheel the whole gearbox shaft and column inside has a weird jump in it when I turn the steering wheel I hope I'm making sense when I say this but it's clearly not right the whole unit is completely moving when turning steering I am wondering could it be the shaft might have got bent and is it hard to replace I have the gearbox off of the 54 meadowbrook I bought but is a different set up as well as the front end suspension but the gearbox and only shaft is there but shaft is cut at the top so my question is can anyone help me with idea or solutions to their issue can I use the gearbox and just replace the shaft that goes inside the gearbox or what would be recommended please any help is greatly appreciated I can also be reached on other email crisjr1469@gmail.com  thank you and have a good day hope to get some help on this one it's really confusing issue ( OK update I have uploaded the videos on my YouTube for anyone to view and maybe help me out with this situation)

20220828_144027.jpg

Screenshot_20221120-074522_Photos.jpg

20220828_144210.jpg

20220828_144224.jpg

Edited by Crisjr14
Wording
Link to comment
Share on other sites

When you replaced the rubber steering box isolators did you reinstall the metal anti crush tubes that go between the rubber pieces inside the actual chassis?.......also there should be some small thin pressed metal "washers" that fit around the rubber extruded pieces to support the rubber........these thin "washers" can sometimes be worn or not reinstalled.......also just a hint.........whilst the steering box does have a type of gear inside it its generally referred to as the "steering box"...........the term gearbox is generally used in relation to the transmission..........andyd     

Link to comment
Share on other sites

Andy so as for the insulators yes I did put them back in and the "washers" those are called ferrules I believe and I could not find them anywhere some where fragile but all in all I got them all to seat right just looking for someway to send someone videos of what I was able to take tried here and keeps saying file to large and thank you for the correction on steering box edit they are youtibe under my other email please don't laugh at it is under Dontremembershit@gmail.com

Edited by Crisjr14
Correction
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Terms of Use