Jump to content
Sign in to follow this  
Probey53

Hesitation

Recommended Posts

I rebuilt the carb , checked the timing its at 4 degrees before , the vacuum advance is working good , wants to pop back through the carb when you try to accelerate .

Any suggestions ?

Share this post


Link to post
Share on other sites

Step up piston..O-Ring gasket and jet OK?

Share this post


Link to post
Share on other sites

Could be lean,, could be valves open early due to too much ignition advance (i.e. balancer slipped and the 4 degrees Before you read at the balancer is really much higher.....)

 

http://www.mikuni.com/tg_backfires_through.html

Edited by Sharps40

Share this post


Link to post
Share on other sites

Just ran into a slipped balancer on a 1935 C2 Airflow couple last week! Off by over an inch!

Share this post


Link to post
Share on other sites

It did not wobble at all. Cracking at the rubber to metal pieces ... Not bad looking though.

Share this post


Link to post
Share on other sites

well if you might be facing inaccurate damper markings, do a static timing to TDC then check with your light, if it is not reading TDC at idle give or take a degree, than that would suggest your marks are off. You can adjust timing by vacuum gauge.  Set idle to 500, attach vacuum gauge to intake adjust timing to highest steady reading, redo idle back to 500 if necessary and drive the vehicle.  This will usually give you a slightly to advanced setting that may result is a bit of spark knock or ping under load, accelerating or climbing a hill.  If that occurs retard the timing  turn dist clockwise) in small increments till your ping knock pre ignition is gone  this will give you a setting that reflects your actual driving conditions, and fuel.  But you should still look into the crank pulley situation.

Share this post


Link to post
Share on other sites

That had to be difficult to find.

We took one off another correct eight cylinder engine. Not an easy job though as the radiator has to come out-not an easy job.. The cooling fan runs off the crank pulley on these big Airflows.

Odd cars for sure.

Share this post


Link to post
Share on other sites

It seems to be getting a good squirt from the acc pump there is an extra white mark on the damper so i will look into that .

I will take #1 plug out and find tdc and find out where its at .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Terms of Use