Jump to content
Thomba48

wiper motor engine linkage set-up

Recommended Posts

Having taken out the wiper motor in the dark I  unfortunately did not really see how the wiper linkage is attached to the motor. Does anybody have a picture that can guide me? I do not see how the linkage is being hold down to the wiper motor itself?

Edited by Thomba48

Share this post


Link to post
Share on other sites

Picture of arm with bushing felt washer underside and felt washer and thin steel washer and then the clip. If I remember correctly this is the same as used on the crank mechanisms to hold the arms on the glass slide?? Same size ?

On my 50Ply. wiper arms the bushings were bad so I replaced them with a rubber grommet, thin washers and a standard type E clip, I think others call the clip style as a cir-clip?

 

Hope this comes through and is a help.

 

DJ

 

 

CCF07292018_00000 (2).jpg

Share this post


Link to post
Share on other sites
On 7/29/2018 at 8:03 PM, DJ194950 said:

Picture of arm with bushing felt washer underside and felt washer and thin steel washer and then the clip. If I remember correctly this is the same as used on the crank mechanisms to hold the arms on the glass slide?? Same size ?

On my 50Ply. wiper arms the bushings were bad so I replaced them with a rubber grommet, thin washers and a standard type E clip, I think others call the clip style as a cir-clip?

 

Hope this comes through and is a help.

 

DJ

 

 

CCF07292018_00000 (2).jpg

My set-up is completely different.
 

Rubber, inside in the shape of the nut.

But the rubber is too dry and breaking apart. So I desperately need the bushings. Where? I need one nut screw as it is missing. Where? I have not found this type of E-clip yet. thanks

Share this post


Link to post
Share on other sites

The rubber parts are Not available anywhere as far I I know which is why I used rubber wire grommets. As long as they fit the arms and the square? or 6 sided Pivots(which it is I forget) but does not matter as the pivots at the arm end Are the point they  where they were meant to move Not at the rubbers.

 

AS far as the retainer clips, I did not have them either. The picture of the parts I showed you was of an electric Mopar wiper parts I was given Long after I had installed the wiper setup in my 50 PLy. 4 dr..

I used a thin washer on the inside and outside of the Rubber grommets with regular E-clips from the local hardware store.

8 years later still working and NO  ONE can ever see the changes without removing the wiper and arms!

 

DJ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Terms of Use