Jump to content

Phil Kelly

Members
  • Content Count

    3
  • Joined

  • Last visited

About Phil Kelly

  • Rank
    Newbie

Profile Information

  • My Project Cars
    Chrysler Windsor 1947

Converted

  • Location
    Donnacona, Qc, Canada
  • Interests
    History, aviation, space, old cars

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. So I check the oil pressure relief valve and it's not stuck. Oil filter is new and there is no sludge. For the new gauge, it has a small nylon hose hooked up directly to the block. I've been told that the timming may have something to do with the low oil pressure, but I don't think it's true.
  2. I'm having a bit of trouble with my 1947 Chrysler Windsor. Cold start, I have around 20 pounds at idle. Then it drops to 0 and stays at 0. Idle and cruising. At first I thought it was my gauge, but after a quick check with a modern one, it does the same thing. So I was wondering what could be my problem and what are the normal readings because there is nothing specific in my manuel about oil pressure.
  3. I'm having a bit of trouble with my 1947 Chrysler Windsor. Cold start, I have around 20 pounds at idle. Then it drops to 0 and stays at 0. Idle and cruising. At first I thought it was my gauge, but after a quick check with a modern one, it does the same thing. So I was wondering what could be my problem and what are the normal readings because there is nothing specific in my manuel about oil pressure.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Terms of Use